Blank Screen on administration

  • hgdc
  • hgdc's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
5 months 3 weeks ago #943 by hgdc
hgdc created the topic: Blank Screen on administration
Hi There

Joomla version 3.7.2 / Simple calendar 3.1.8 / PHP 7.1

I am getting a blank screen when I try to do anything from the main component screen - i.e. creating a new event or going to next page etc. Please see picture for the console output and the content of the index.php is

<html>
<head>
<script type="text/javascript">
Joomla.submitbutton = function (task) {
// Check for correct start and end dates
var start_dt = document.getElementById('jform_start_dt');
var end_dt = document.getElementById('jform_end_dt');

var n = start_dt.value.indexOf('.');
//alert(n);
if (n == -1 || isNaN(n)) {
var dateSplit1 = start_dt.value.split('-');
var dateSplit2 = end_dt.value.split('-');
} else {
var dateSplit1 = start_dt.value.split('.');
var dateSplit2 = end_dt.value.split('.');
}
if (dateSplit1[0].length == 4) {
var d1 = new Date(dateSplit1[0], dateSplit1[1] - 1, dateSplit1[2]);
var d2 = new Date(dateSplit2[0], dateSplit2[1] - 1, dateSplit2[2]);
} else {
var d1 = new Date(dateSplit1[2], dateSplit1[1] - 1, dateSplit1[0]);
var d2 = new Date(dateSplit2[2], dateSplit2[1] - 1, dateSplit2[0]);
}
//alert(d1+" "+d2);
if (task != 'event.cancel' && end_dt.value != '' && d1 > d2) {

alert('Warning: end date is greater than start date! Please verify the data');
document.getElementById('jform_end_dt').setAttribute('class', 'input-small invalid');
document.getElementById('jform_end_dt').focus();
return false;
}
else {
if (task == 'event.cancel' || document.formvalidator.isValid(document.id('simplecalendar-form'))) {
</script>
</head>
<body></body>
</html>


Any ideas? Thank you

This message has an attachment image.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

  • hgdc
  • hgdc's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
5 months 3 weeks ago #944 by hgdc
hgdc replied the topic: Blank Screen on administration
OK, switching to PHP 5.6 solves the problem. That's odd as it works on the local host with PHP 7.0.15 ???

Please Log in or Create an account to join the conversation.

Time to create page: 0.245 seconds
Powered by Kunena Forum