google maps not displaying

More
1 year 5 months ago #779 by sami
sami created the topic: google maps not displaying
Hi
I just installed Simple Calender and I really like it.
The issue I have is that the Google map is not displaying on the Website:
swisswushu.wushutraining.ch/index.php/ag...shu-turniere/1-3qt16

In Admin I can see the map but not on the website itself.

What could be the issue?
SimpleCalendar 3.1.1
Joomla! version 3.5.1

Thank you
The topic has been locked.
More
1 year 5 months ago #780 by admin
admin replied the topic: google maps not displaying
You need to have a Location set to a point on the map, or an address that translates to a point on th map to enable Google Maps display.
The best way is to click on "[Show map]" and drag the pointer around.
You can do this with the "Organizer page" as well, so that you don't have to input the address every time, but can rely on it being carried over by the Organizer info.
Hit me back should it not be clear :)
Best regards
Fabrizio
The topic has been locked.
More
1 year 5 months ago #782 by sami
sami replied the topic: google maps not displaying
hi fabrizio
meanwhile i had to deactivate the maps function. Please klick on the link in my forst post again, now you may see the issue I have.

The address is set correctly in admin pannel of joomla and when you click on one of the 3 icons which are (should be) below the maps it redirects you to the right location.

The issue is that it does no show the map on the event it self.

Can you see what I mean?
The topic has been locked.
More
1 year 5 months ago - 1 year 5 months ago #783 by admin
admin replied the topic: google maps not displaying
If you open the image in a new page, it says:
The Google Maps API server rejected your request. This service requires an API key.

It seems that you/your domain hit the limit for the free service... :unsure:
Link: developers.google.com/maps/documentation...tic-maps/intro?hl=de

I will add the possibility of supplying your own API key in a future version of SimpleCalendar.

Fabrizio
Last Edit: 1 year 5 months ago by admin. Reason: Link to dev documents added
The topic has been locked.
More
1 year 5 months ago - 1 year 5 months ago #784 by admin
admin replied the topic: google maps not displaying
Just noticed something else that might interfere (as I haven't heard of anyone reaching the Google Maps API limit for display without an API key...): an add-on called "Designbold", it's in your source code and adds a little "Design it" button to the top-right of all images (see the header for example) and the google maps as well (as it's a static image).
See below
Can you maybe try and remove/disable this plugin/component/whatever and report again?

Fabrizio

This message has an attachment image.
Please log in or register to see it.

Last Edit: 1 year 5 months ago by admin.
The topic has been locked.
More
1 year 5 months ago #785 by sami
sami replied the topic: google maps not displaying
Hi
I've disabled the plug-in. Unfortunately still the same issue. Any other hints?

Regards,
Sami
The topic has been locked.
Time to create page: 0.292 seconds
Powered by Kunena Forum